Improper Neutralization of Special Elements used in a Command in Apache Cassandra
CVE-2015-0225GHSA-w7f2-gjxf-2gm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cassandra:apache-cassandra 2.1.4, 2.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.cassandra:apache-cassandra
- Affected
- >= 1.2.0, < 2.0.14>= 2.1.0, < 2.1.4
- Fixed in
- 2.0.14, 2.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w7f2-gjxf-2gm9 lists affected ranges: Maven org.apache.cassandra:apache-cassandra >=1.2.0 =2.1.0 <2.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2015-0225: 6.64% estimated exploitation activity in the next 30 days; percentile 93.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The default configuration in Apache Cassandra 1.2.0 through 1.2.19, 2.0.0 through 2.0.13, and 2.1.0 through 2.1.3 binds an unauthenticated JMX/RMI interface to all network interfaces, which allows remote attackers to execute arbitrary Java code via an RMI request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w7f2-gjxf-2gm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2015-0225 Advisory: Improper Neutralization of Special Elements used in a Command in Apache Cassandra IDs: CVE-2015-0225, GHSA-w7f2-gjxf-2gm9 Record: https://patchnext.com/advisories/cve-2015-0225 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.cassandra:apache-cassandra 2.1.4, 2.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.cassandra:apache-cassandra: affected >= 1.2.0, < 2.0.14; >= 2.1.0, < 2.1.4; fixed in 2.0.14, 2.1.4 ## Suggested inspection (read-only) - Maven org.apache.cassandra:apache-cassandra: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.cassandra:apache-cassandra. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w7f2-gjxf-2gm9 (GitHub-reviewed advisory GHSA-w7f2-gjxf-2gm9 lists affected ranges: Maven org.apache.cassandra:apache-cassandra >=1.2.0 =2.1.0 <2.1.4) Commands are suggestions: review each one before running it.
Loading voting…