Exposure of Sensitive Information to an Unauthorized Actor in Apache Jasypt
CVE-2014-9970GHSA-r5c2-rxh2-f5h2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jasypt:jasypt 1.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jasypt:jasypt
- Affected
- < 1.9.2
- Fixed in
- 1.9.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r5c2-rxh2-f5h2 lists affected ranges: Maven org.jasypt:jasypt >=0 <1.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2014-9970: 2.37% estimated exploitation activity in the next 30 days; percentile 83.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
jasypt before 1.9.2 allows a timing attack against the password hash comparison.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r5c2-rxh2-f5h2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-9970 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Apache Jasypt IDs: CVE-2014-9970, GHSA-r5c2-rxh2-f5h2 Record: https://patchnext.com/advisories/cve-2014-9970 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jasypt:jasypt 1.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jasypt:jasypt: affected < 1.9.2; fixed in 1.9.2 ## Suggested inspection (read-only) - Maven org.jasypt:jasypt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jasypt:jasypt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r5c2-rxh2-f5h2 (GitHub-reviewed advisory GHSA-r5c2-rxh2-f5h2 lists affected ranges: Maven org.jasypt:jasypt >=0 <1.9.2) Commands are suggestions: review each one before running it.
Loading voting…