Dulwich Arbitrary code execution via commit with directory path starting with .git
CVE-2014-9706GHSA-4j5j-58j7-6c3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dulwich 0.9.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dulwich
- Affected
- < 0.9.10
- Fixed in
- 0.9.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4j5j-58j7-6c3w lists affected ranges: PyPI dulwich >=0 <0.9.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4j5j-58j7-6c3w lists affected ranges: PyPI dulwich >=0 <0.9.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-9706: 5.00% estimated exploitation activity in the next 30 days; percentile 92.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The buildindexfromtree function in index.py in Dulwich versions 0.9.9 and below allows remote attackers to execute arbitrary code via a commit with a directory path starting with .git/, which is not properly handled when checking out a working tree.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4j5j-58j7-6c3w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4j5j-58j7-6c3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-9706 Advisory: Dulwich Arbitrary code execution via commit with directory path starting with .git IDs: CVE-2014-9706, GHSA-4j5j-58j7-6c3w Record: https://patchnext.com/advisories/cve-2014-9706 (revision 3, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dulwich 0.9.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dulwich: affected < 0.9.10; fixed in 0.9.10 ## Suggested inspection (read-only) - `python -m pip show dulwich`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dulwich. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4j5j-58j7-6c3w (OSV record GHSA-4j5j-58j7-6c3w lists affected ranges: PyPI dulwich >=0 <0.9.10 (fixed)) - Verified: https://github.com/advisories/GHSA-4j5j-58j7-6c3w (GitHub-reviewed advisory GHSA-4j5j-58j7-6c3w lists affected ranges: PyPI dulwich >=0 <0.9.10) Commands are suggestions: review each one before running it.
Loading voting…