JGit Improper Input Validation vulnerability
CVE-2014-9390GHSA-6vvc-c2m3-cjf3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mercurial 3.2.3; org.eclipse.jgit:org.eclipse.jgit 3.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mercurial
- Affected
- < 3.2.3
- Fixed in
- 3.2.3
Maven org.eclipse.jgit:org.eclipse.jgit
- Affected
- < 3.5.3
- Fixed in
- 3.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6vvc-c2m3-cjf3 lists affected ranges: Maven org.eclipse.jgit:org.eclipse.jgit >=0 =0 <3.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6vvc-c2m3-cjf3 lists affected ranges: Maven org.eclipse.jgit:org.eclipse.jgit >=0 =0 <3.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-9390: 75.60% estimated exploitation activity in the next 30 days; percentile 99.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine; libgit2; Egit; and JGit allow remote Git servers to execute arbitrary commands via a tree containing a crafted .git/config file with (1) an ignorable Unicode codepoint, (2) a git~1/config representation, or (3) mixed case that is improperly handled on a case-insensitive filesystem.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6vvc-c2m3-cjf3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6vvc-c2m3-cjf3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-9390 Advisory: JGit Improper Input Validation vulnerability IDs: CVE-2014-9390, GHSA-6vvc-c2m3-cjf3 Record: https://patchnext.com/advisories/cve-2014-9390 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mercurial 3.2.3; org.eclipse.jgit:org.eclipse.jgit 3.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mercurial: affected < 3.2.3; fixed in 3.2.3 - Maven org.eclipse.jgit:org.eclipse.jgit: affected < 3.5.3; fixed in 3.5.3 ## Suggested inspection (read-only) - `python -m pip show mercurial`: prints the installed version. Run with the environment that serves production active. - Maven org.eclipse.jgit:org.eclipse.jgit: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mercurial, org.eclipse.jgit:org.eclipse.jgit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6vvc-c2m3-cjf3 (OSV record GHSA-6vvc-c2m3-cjf3 lists affected ranges: Maven org.eclipse.jgit:org.eclipse.jgit >=0 =0 <3.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-6vvc-c2m3-cjf3 (GitHub-reviewed advisory GHSA-6vvc-c2m3-cjf3 lists affected ranges: Maven org.eclipse.jgit:org.eclipse.jgit >=0 =0 <3.2.3) Commands are suggestions: review each one before running it.
Loading voting…