Smarty arbitrary PHP code execution
CVE-2014-8350GHSA-2pmx-6mm6-6v72
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smarty/smarty 3.1.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist smarty/smarty
- Affected
- < 3.1.21
- Fixed in
- 3.1.21
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2pmx-6mm6-6v72 lists affected ranges: Packagist smarty/smarty >=0 <3.1.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-8350: 3.13% estimated exploitation activity in the next 30 days; percentile 87.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php" in a template.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2pmx-6mm6-6v72
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-8350 Advisory: Smarty arbitrary PHP code execution IDs: CVE-2014-8350, GHSA-2pmx-6mm6-6v72 Record: https://patchnext.com/advisories/cve-2014-8350 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: smarty/smarty 3.1.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist smarty/smarty: affected < 3.1.21; fixed in 3.1.21 ## Suggested inspection (read-only) - Packagist smarty/smarty: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on smarty/smarty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2pmx-6mm6-6v72 (GitHub-reviewed advisory GHSA-2pmx-6mm6-6v72 lists affected ranges: Packagist smarty/smarty >=0 <3.1.21) Commands are suggestions: review each one before running it.
Loading voting…