Skip to content

← Actionable
Medium, CVSS 5.3

DCE extension for Typo3 Discloses Environment Information

CVE-2014-8328GHSA-v4vm-gj2x-6qhm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (t3/dce 0.11.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist t3/dce

    Affected
    < 0.11.5
    Fixed in
    0.11.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2014-8328: 1.58% estimated exploitation activity in the next 30 days; percentile 75.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The default configuration in the Dynamic Content Elements (dce) extension before 0.11.5 for TYPO3 allows remote attackers to obtain sensitive installation environment information by reading the update check request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v4vm-gj2x-6qhm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-8328

Advisory: DCE extension for Typo3 Discloses Environment Information
IDs: CVE-2014-8328, GHSA-v4vm-gj2x-6qhm
Record: https://patchnext.com/advisories/cve-2014-8328 (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: t3/dce 0.11.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist t3/dce: affected < 0.11.5; fixed in 0.11.5

## Suggested inspection (read-only)
- Packagist t3/dce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on t3/dce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v4vm-gj2x-6qhm (GitHub-reviewed advisory GHSA-v4vm-gj2x-6qhm lists affected ranges: Packagist t3/dce >=0 <0.11.5)

Commands are suggestions: review each one before running it.

Loading voting…