Moodle Temporary Passwords are Brute Force-able
CVE-2014-7845GHSA-9v64-447r-wch6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.7.3, 2.6.6, 2.5.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 2.7.0, <= 2.7.2>= 2.6.0, <= 2.6.5>= 2.5.0, <= 2.5.8
- Fixed in
- 2.7.3, 2.5.9, 2.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9v64-447r-wch6 lists affected ranges: Packagist moodle/moodle >=2.7.0 =2.6.0 =2.5.0 <=2.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-7845: 2.41% estimated exploitation activity in the next 30 days; percentile 84.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The generatepassword function in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide a sufficient number of possible temporary passwords, which allows remote attackers to obtain access via a brute-force attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9v64-447r-wch6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-7845 Advisory: Moodle Temporary Passwords are Brute Force-able IDs: CVE-2014-7845, GHSA-9v64-447r-wch6 Record: https://patchnext.com/advisories/cve-2014-7845 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.7.3, 2.6.6, 2.5.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 2.7.0, <= 2.7.2; >= 2.6.0, <= 2.6.5; >= 2.5.0, <= 2.5.8; fixed in 2.7.3, 2.5.9, 2.6.6 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9v64-447r-wch6 (GitHub-reviewed advisory GHSA-9v64-447r-wch6 lists affected ranges: Packagist moodle/moodle >=2.7.0 =2.6.0 =2.5.0 <=2.5.8) Commands are suggestions: review each one before running it.
Loading voting…