Moodle allows attackers to remove wiki pages
CVE-2014-7837GHSA-p3hj-cfhm-7g6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.7.3, 2.6.6, 2.5.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- < 2.5.9>= 2.6.0, < 2.6.6>= 2.7.0, < 2.7.3
- Fixed in
- 2.7.3, 2.5.9, 2.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p3hj-cfhm-7g6v lists affected ranges: Packagist moodle/moodle >=0 =2.6.0 =2.7.0 <2.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-7837: 1.91% estimated exploitation activity in the next 30 days; percentile 79.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
mod/wiki/admin.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote authenticated users to remove wiki pages by leveraging delete access within a different subwiki.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p3hj-cfhm-7g6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-7837 Advisory: Moodle allows attackers to remove wiki pages IDs: CVE-2014-7837, GHSA-p3hj-cfhm-7g6v Record: https://patchnext.com/advisories/cve-2014-7837 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.7.3, 2.6.6, 2.5.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected < 2.5.9; >= 2.6.0, < 2.6.6; >= 2.7.0, < 2.7.3; fixed in 2.7.3, 2.5.9, 2.6.6 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p3hj-cfhm-7g6v (GitHub-reviewed advisory GHSA-p3hj-cfhm-7g6v lists affected ranges: Packagist moodle/moodle >=0 =2.6.0 =2.7.0 <2.7.3) Commands are suggestions: review each one before running it.
Loading voting…