Skip to content

← Actionable
Unrated

phpMyAdmin cross-site scripting Vulnerability via ENUM value

CVE-2014-7217GHSA-wv8g-fx9j-q2jg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 4.2.9.1, 4.1.14.5, 4.0.10.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpmyadmin/phpmyadmin

    Affected
    >= 4.0.0, < 4.0.10.4>= 4.1.0, < 4.1.14.5>= 4.2.0, < 4.2.9.1
    Fixed in
    4.0.10.4, 4.1.14.5, 4.2.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-7217: 1.62% estimated exploitation activity in the next 30 days; percentile 76.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted ENUM value that is improperly handled during rendering of the (1) table search or (2) table structure page, related to libraries/TableSearch.class.php and libraries/Util.class.php.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wv8g-fx9j-q2jg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-7217

Advisory: phpMyAdmin cross-site scripting Vulnerability via ENUM value
IDs: CVE-2014-7217, GHSA-wv8g-fx9j-q2jg
Record: https://patchnext.com/advisories/cve-2014-7217 (revision 1, source checked 26 Oct 2026, 14:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 4.2.9.1, 4.1.14.5, 4.0.10.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpmyadmin/phpmyadmin: affected >= 4.0.0, < 4.0.10.4; >= 4.1.0, < 4.1.14.5; >= 4.2.0, < 4.2.9.1; fixed in 4.0.10.4, 4.1.14.5, 4.2.9.1

## Suggested inspection (read-only)
- Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpmyadmin/phpmyadmin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wv8g-fx9j-q2jg (GitHub-reviewed advisory GHSA-wv8g-fx9j-q2jg lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.0.0 =4.1.0 =4.2.0 <4.2.9.1)

Commands are suggestions: review each one before running it.

Loading voting…