Skip to content

← Actionable
Unratedamended

CORS Token Disclosure in crumb

CVE-2014-7193GHSA-84fq-6626-w5fg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (crumb 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm crumb

    Affected
    < 3.0.0
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-7193: 1.37% estimated exploitation activity in the next 30 days; percentile 71.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When CORS is enabled on a hapi route handler, it is possible to set a crumb token for a different domain. An attacker would need to have an application consumer visit a site they control, request a route supporting CORS, and then retrieve the token. With this token, they could possibly make requests to non CORS routes as this user. A configuration and scenario where this would occur is unlikely, as most configurations will set CORS globally (where crumb is not used), or not at all. Recommendation Update to version 3.0.0 or greater.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-84fq-6626-w5fg

  2. Revision 1 · created ·

    Published from osv record GHSA-84fq-6626-w5fg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-7193

Advisory: CORS Token Disclosure in crumb
IDs: CVE-2014-7193, GHSA-84fq-6626-w5fg
Record: https://patchnext.com/advisories/cve-2014-7193 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: crumb 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm crumb: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `npm ls crumb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on crumb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-84fq-6626-w5fg (OSV record GHSA-84fq-6626-w5fg lists affected ranges: npm crumb >=0 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-84fq-6626-w5fg (GitHub-reviewed advisory GHSA-84fq-6626-w5fg lists affected ranges: npm crumb >=0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…