Potential for Script Injection in syntax-error
CVE-2014-7192GHSA-5726-g6r9-5f22
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (syntax-error 1.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm syntax-error
- Affected
- < 1.1.1
- Fixed in
- 1.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5726-g6r9-5f22 lists affected ranges: npm syntax-error >=0 <1.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5726-g6r9-5f22 lists affected ranges: npm syntax-error >=0 <1.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-7192: 13.05% estimated exploitation activity in the next 30 days; percentile 96.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of syntax-error prior to 1.1.1 are affected by a cross-site scripting vulnerability which may allow a malicious file to execute code when browserified. Recommendation Update to version 1.1.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5726-g6r9-5f22
- Revision 1 · created ·
Published from osv record GHSA-5726-g6r9-5f22
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-7192 Advisory: Potential for Script Injection in syntax-error IDs: CVE-2014-7192, GHSA-5726-g6r9-5f22 Record: https://patchnext.com/advisories/cve-2014-7192 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: syntax-error 1.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm syntax-error: affected < 1.1.1; fixed in 1.1.1 ## Suggested inspection (read-only) - `npm ls syntax-error --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on syntax-error. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5726-g6r9-5f22 (OSV record GHSA-5726-g6r9-5f22 lists affected ranges: npm syntax-error >=0 <1.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5726-g6r9-5f22 (GitHub-reviewed advisory GHSA-5726-g6r9-5f22 lists affected ranges: npm syntax-error >=0 <1.1.1) Commands are suggestions: review each one before running it.
Loading voting…