Skip to content

← Actionable
High, CVSS 8.7amended

Python Twisted trustRoot is not respected in HTTP client

CVE-2014-7143GHSA-3c45-wgjp-7v9r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twisted 14.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI twisted

    Affected
    >= 14.0.0, <= 14.0.0
    Fixed in
    14.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2014-7143: 2.61% estimated exploitation activity in the next 30 days; percentile 85.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Python Twisted 14.0.0 trustRoot is not respected in HTTP client

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3c45-wgjp-7v9r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3c45-wgjp-7v9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-7143

Advisory: Python Twisted trustRoot is not respected in HTTP client
IDs: CVE-2014-7143, GHSA-3c45-wgjp-7v9r
Record: https://patchnext.com/advisories/cve-2014-7143 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twisted 14.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI twisted: affected >= 14.0.0, <= 14.0.0; fixed in 14.0.1

## Suggested inspection (read-only)
- `python -m pip show twisted`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twisted.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3c45-wgjp-7v9r (OSV record GHSA-3c45-wgjp-7v9r lists affected ranges: PyPI twisted >=14.0.0 <14.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3c45-wgjp-7v9r (GitHub-reviewed advisory GHSA-3c45-wgjp-7v9r lists affected ranges: PyPI twisted >=14.0.0 <=14.0.0)

Commands are suggestions: review each one before running it.

Loading voting…