WEC Map (wec_map) extension for TYPO3 allows Cross-site Scripting
CVE-2014-6296GHSA-mqhg-c7w9-w3cv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-tp3/wec_map 3.0.3; jbartels/wec-map 3.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist web-tp3/wec_map
- Affected
- < 3.0.3
- Fixed in
- 3.0.3
Packagist jbartels/wec-map
- Affected
- < 3.0.3
- Fixed in
- 3.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mqhg-c7w9-w3cv lists affected ranges: Packagist web-tp3/wec_map >=0 =0 <3.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2014-6296: 0.93% estimated exploitation activity in the next 30 days; percentile 60.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the WEC Map (wecmap) extension before 3.0.3 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mqhg-c7w9-w3cv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-6296 Advisory: WEC Map (wec_map) extension for TYPO3 allows Cross-site Scripting IDs: CVE-2014-6296, GHSA-mqhg-c7w9-w3cv Record: https://patchnext.com/advisories/cve-2014-6296 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: web-tp3/wec_map 3.0.3; jbartels/wec-map 3.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist web-tp3/wec_map: affected < 3.0.3; fixed in 3.0.3 - Packagist jbartels/wec-map: affected < 3.0.3; fixed in 3.0.3 ## Suggested inspection (read-only) - Packagist web-tp3/wec_map: check the installed version with your package manager. - Packagist jbartels/wec-map: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on web-tp3/wec_map, jbartels/wec-map. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mqhg-c7w9-w3cv (GitHub-reviewed advisory GHSA-mqhg-c7w9-w3cv lists affected ranges: Packagist web-tp3/wec_map >=0 =0 <3.0.3) Commands are suggestions: review each one before running it.
Loading voting…