Skip to content

← Actionable
High, CVSS 8.1

Symfony Cross-Site Request Forgery vulnerability in the Web Profiler

CVE-2014-6072GHSA-v35g-4rrw-h4fw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.5.4, 2.4.9, 2.3.19; symfony/web-profiler-bundle 2.5.4, 2.4.9, 2.3.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.0.0, < 2.3.19>= 2.4.0, < 2.4.9>= 2.5.0, < 2.5.4
    Fixed in
    2.5.4, 2.3.19, 2.4.9
  • Packagist symfony/web-profiler-bundle

    Affected
    >= 2.0.0, < 2.3.19>= 2.4.0, < 2.4.9>= 2.5.0, < 2.5.4
    Fixed in
    2.5.4, 2.3.19, 2.4.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

All 2.0.X, 2.1.X, 2.2.X, 2.3.X, 2.4.X, and 2.5.X versions of the Symfony WebProfiler bundle are affected by this security issue. This issue has been fixed in Symfony 2.3.19, 2.4.9, and 2.5.4. Note that no fixes are provided for Symfony 2.0, 2.1, and 2.2 as they are not maintained anymore. Description The Symfony Web Profiler is a great development tool, but it should not be enabled on production servers. If it is enabled in production, it must be properly secured so that only authorized people have access to it. Developers must be very cautious about this as the Web Profiler gives many sensitive information about a Symfony project and any attackers can exploit many of them. Just to name a few sensitive information: user logins, user cookies, executed SQL statements, ... That being said, the import/export feature of the web profiler is exploitable even if the Web Profiler is secured as the form to import a profiler is not protected against CSRF attacks. Combined with the fact that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v35g-4rrw-h4fw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-6072

Advisory: Symfony Cross-Site Request Forgery vulnerability in the Web Profiler
IDs: CVE-2014-6072, GHSA-v35g-4rrw-h4fw
Record: https://patchnext.com/advisories/cve-2014-6072 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.5.4, 2.4.9, 2.3.19; symfony/web-profiler-bundle 2.5.4, 2.4.9, 2.3.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.0.0, < 2.3.19; >= 2.4.0, < 2.4.9; >= 2.5.0, < 2.5.4; fixed in 2.5.4, 2.3.19, 2.4.9
- Packagist symfony/web-profiler-bundle: affected >= 2.0.0, < 2.3.19; >= 2.4.0, < 2.4.9; >= 2.5.0, < 2.5.4; fixed in 2.5.4, 2.3.19, 2.4.9

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/web-profiler-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/web-profiler-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v35g-4rrw-h4fw (GitHub-reviewed advisory GHSA-v35g-4rrw-h4fw lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.4.0 =2.5.0 =2.0.0 =2.4.0 =2.5.0 <2.5.4)

Commands are suggestions: review each one before running it.

Loading voting…