Man-in-the-Middle (MitM)
CVE-2014-5277GHSA-8w94-cf6g-c8mg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 1.3.1; docker-py 0.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.3.1
- Fixed in
- 1.3.1
PyPI docker-py
- Affected
- < 0.5.3
- Fixed in
- 0.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2014-80 lists affected ranges: PyPI docker-py >=0 <0.5.3 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8w94-cf6g-c8mg lists affected ranges: Go github.com/docker/docker >=0 <1.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-5277: 1.87% estimated exploitation activity in the next 30 days; percentile 79.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Docker before 1.3.1 and docker-py before 0.5.3 fall back to HTTP when the HTTPS connection to the registry fails, which allows man-in-the-middle attackers to conduct downgrade attacks and obtain authentication and image data by leveraging a network position between the client and the registry to block HTTPS traffic.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8w94-cf6g-c8mg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record PYSEC-2014-80
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-5277 Advisory: Man-in-the-Middle (MitM) IDs: CVE-2014-5277, GHSA-8w94-cf6g-c8mg Record: https://patchnext.com/advisories/cve-2014-5277 (revision 3, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 1.3.1; docker-py 0.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/docker/docker: affected < 1.3.1; fixed in 1.3.1 - PyPI docker-py: affected < 0.5.3; fixed in 0.5.3 ## Suggested inspection (read-only) - Go github.com/docker/docker: check the installed version with your package manager. - `python -m pip show docker-py`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/docker/docker, docker-py. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2014-80 (OSV record PYSEC-2014-80 lists affected ranges: PyPI docker-py >=0 <0.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-8w94-cf6g-c8mg (GitHub-reviewed advisory GHSA-8w94-cf6g-c8mg lists affected ranges: Go github.com/docker/docker >=0 <1.3.1) Commands are suggestions: review each one before running it.
Loading voting…