Skip to content

← Actionable
High, CVSS 7.5

Symfony allows direct access of ESI URLs behind a trusted proxy

CVE-2014-5245GHSA-wvjv-p5rr-mmqm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.5.4, 2.4.9, 2.3.19; symfony/http-kernel 2.5.4, 2.4.9, 2.3.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.0.0, < 2.3.19>= 2.4.0, < 2.4.9>= 2.5.0, < 2.5.4
    Fixed in
    2.5.4, 2.3.19, 2.4.9
  • Packagist symfony/http-kernel

    Affected
    >= 2.0.0, < 2.3.19>= 2.4.0, < 2.4.9>= 2.5.0, < 2.5.4
    Fixed in
    2.5.4, 2.3.19, 2.4.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

All 2.2.X, 2.3.X, 2.4.X, and 2.5.X versions of the Symfony HttpKernel component are affected by this security issue. Your application is vulnerable only if the ESI feature is enabled and there is a proxy in front of the web application. This issue has been fixed in Symfony 2.3.19, 2.4.9, and 2.5.4. Note that no fixes are provided for Symfony 2.2 as it is not maintained anymore. Description When you enable the ESI feature and when you are using a proxy like Varnish that you configured as a trusted proxy, the FragmentHandler considered requests to render fragments as coming from a trusted source, even if the client was requesting them directly. Symfony can not distinguish between ESI requests done on behalf of the client by Varnish and faked fragment requests coming directly from the client. To mitigate this issue, and for not-supported Symfony versions, you can use the following workaround in your Varnish configuration (/fragment being the URL path prefix configured under the fragment…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wvjv-p5rr-mmqm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-5245

Advisory: Symfony allows direct access of ESI URLs behind a trusted proxy
IDs: CVE-2014-5245, GHSA-wvjv-p5rr-mmqm
Record: https://patchnext.com/advisories/cve-2014-5245 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.5.4, 2.4.9, 2.3.19; symfony/http-kernel 2.5.4, 2.4.9, 2.3.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.0.0, < 2.3.19; >= 2.4.0, < 2.4.9; >= 2.5.0, < 2.5.4; fixed in 2.5.4, 2.3.19, 2.4.9
- Packagist symfony/http-kernel: affected >= 2.0.0, < 2.3.19; >= 2.4.0, < 2.4.9; >= 2.5.0, < 2.5.4; fixed in 2.5.4, 2.3.19, 2.4.9

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/http-kernel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/http-kernel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wvjv-p5rr-mmqm (GitHub-reviewed advisory GHSA-wvjv-p5rr-mmqm lists affected ranges: Packagist symfony/http-kernel >=2.0.0 =2.4.0 =2.5.0 =2.0.0 =2.4.0 =2.5.0 <2.5.4)

Commands are suggestions: review each one before running it.

Loading voting…