Skip to content

← Actionable
High, CVSS 7.5

Code injection in the way Symfony implements translation caching in FrameworkBundle

CVE-2014-4931GHSA-wfv7-5x33-v22h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/framework-bundle 2.5.2, 2.4.8, 2.3.18; symfony/symfony 2.5.4, 2.4.9, 2.3.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/framework-bundle

    Affected
    >= 2.0.0, < 2.3.18>= 2.4.0, < 2.4.8>= 2.5.0, < 2.5.2
    Fixed in
    2.3.18, 2.4.8, 2.5.2
  • Packagist symfony/symfony

    Affected
    >= 2.0.0, < 2.3.19>= 2.4.0, < 2.4.9>= 2.5.0, < 2.5.4
    Fixed in
    2.5.4, 2.3.19, 2.4.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

When investigating issue #11093, Jeremy Derussé found a serious code injection issue in the way Symfony implements translation caching in FrameworkBundle. - Your Symfony application is vulnerable if you meet the following conditions: - You are using the Symfony translation system from FrameworkBundle (so basically if you are using Symfony full-stack -- you are not affected if you are using the Translation component with Silex for instance); You don't sanitize locales coming from a URL (any route with a locale argument for instance): When vulnerable, an attacker can submit a non-valid locale value that can contain some PHP code that will be executed by Symfony. That's because the locale value is dumped into a PHP file generated in the cache without being sanitized first.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wfv7-5x33-v22h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-4931

Advisory: Code injection in the way Symfony implements translation caching in FrameworkBundle
IDs: CVE-2014-4931, GHSA-wfv7-5x33-v22h
Record: https://patchnext.com/advisories/cve-2014-4931 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/framework-bundle 2.5.2, 2.4.8, 2.3.18; symfony/symfony 2.5.4, 2.4.9, 2.3.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/framework-bundle: affected >= 2.0.0, < 2.3.18; >= 2.4.0, < 2.4.8; >= 2.5.0, < 2.5.2; fixed in 2.3.18, 2.4.8, 2.5.2
- Packagist symfony/symfony: affected >= 2.0.0, < 2.3.19; >= 2.4.0, < 2.4.9; >= 2.5.0, < 2.5.4; fixed in 2.5.4, 2.3.19, 2.4.9

## Suggested inspection (read-only)
- Packagist symfony/framework-bundle: check the installed version with your package manager.
- Packagist symfony/symfony: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/framework-bundle, symfony/symfony.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wfv7-5x33-v22h (GitHub-reviewed advisory GHSA-wfv7-5x33-v22h lists affected ranges: Packagist symfony/framework-bundle >=2.0.0 =2.4.0 =2.5.0 =2.0.0 =2.4.0 =2.5.0 <2.5.4)

Commands are suggestions: review each one before running it.

Loading voting…