Skip to content

← Actionable
Unratedamended

OpenStack Compute (Nova) Denial of Service vulnerability

CVE-2014-3708GHSA-43hc-pwvx-pmfg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nova 2014.2.1, 2014.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nova

    Affected
    < 2014.1.4>= 2014.2.0, < 2014.2.1
    Fixed in
    2014.2.1, 2014.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-3708: 2.81% estimated exploitation activity in the next 30 days; percentile 86.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenStack Compute (Nova) before 2014.1.4 and 2014.2.x before 2014.2.1 allows remote authenticated users to cause a denial of service (CPU consumption) via an IP filter in a list active servers API request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-43hc-pwvx-pmfg

  2. Revision 1 · created ·

    Published from osv record GHSA-43hc-pwvx-pmfg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-3708

Advisory: OpenStack Compute (Nova) Denial of Service vulnerability
IDs: CVE-2014-3708, GHSA-43hc-pwvx-pmfg
Record: https://patchnext.com/advisories/cve-2014-3708 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nova 2014.2.1, 2014.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nova: affected < 2014.1.4; >= 2014.2.0, < 2014.2.1; fixed in 2014.2.1, 2014.1.4

## Suggested inspection (read-only)
- `python -m pip show nova`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nova.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-43hc-pwvx-pmfg (OSV record GHSA-43hc-pwvx-pmfg lists affected ranges: PyPI nova >=0 =2014.2.0 <2014.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-43hc-pwvx-pmfg (GitHub-reviewed advisory GHSA-43hc-pwvx-pmfg lists affected ranges: PyPI nova >=0 =2014.2.0 <2014.2.1)

Commands are suggestions: review each one before running it.

Loading voting…