Jenkins Monitoring Plugin Reveals Sensitive Information via Unspecified Pages
CVE-2014-3679GHSA-qwc3-p5pc-q93h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jvnet.hudson.plugins:monitoring 1.53.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jvnet.hudson.plugins:monitoring
- Affected
- < 1.53.0
- Fixed in
- 1.53.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qwc3-p5pc-q93h lists affected ranges: Maven org.jvnet.hudson.plugins:monitoring >=0 <1.53.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-3679: 1.78% estimated exploitation activity in the next 30 days; percentile 78.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Monitoring plugin before 1.53.0 for Jenkins allows remote attackers to obtain sensitive information by accessing unspecified pages.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qwc3-p5pc-q93h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3679 Advisory: Jenkins Monitoring Plugin Reveals Sensitive Information via Unspecified Pages IDs: CVE-2014-3679, GHSA-qwc3-p5pc-q93h Record: https://patchnext.com/advisories/cve-2014-3679 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jvnet.hudson.plugins:monitoring 1.53.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jvnet.hudson.plugins:monitoring: affected < 1.53.0; fixed in 1.53.0 ## Suggested inspection (read-only) - Maven org.jvnet.hudson.plugins:monitoring: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jvnet.hudson.plugins:monitoring. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qwc3-p5pc-q93h (GitHub-reviewed advisory GHSA-qwc3-p5pc-q93h lists affected ranges: Maven org.jvnet.hudson.plugins:monitoring >=0 <1.53.0) Commands are suggestions: review each one before running it.
Loading voting…