Jenkins Path Traversal vulnerability
CVE-2014-3664GHSA-3gp5-92h5-h855
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 1.583, 1.565.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.main:jenkins-core
- Affected
- >= 1.566, < 1.583< 1.565.3
- Fixed in
- 1.583, 1.565.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3gp5-92h5-h855 lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=1.566 =0 <1.565.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-3664: 2.47% estimated exploitation activity in the next 30 days; percentile 84.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory traversal vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote authenticated users with the Overall/READ permission to read arbitrary files via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3gp5-92h5-h855
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3664 Advisory: Jenkins Path Traversal vulnerability IDs: CVE-2014-3664, GHSA-3gp5-92h5-h855 Record: https://patchnext.com/advisories/cve-2014-3664 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 1.583, 1.565.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.main:jenkins-core: affected >= 1.566, < 1.583; < 1.565.3; fixed in 1.583, 1.565.3 ## Suggested inspection (read-only) - Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.main:jenkins-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3gp5-92h5-h855 (GitHub-reviewed advisory GHSA-3gp5-92h5-h855 lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=1.566 =0 <1.565.3) Commands are suggestions: review each one before running it.
Loading voting…