Skip to content

← Actionable
Unrated

Moodle allows discovery of an author's username

CVE-2014-3617GHSA-p5j7-26wj-423j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.7.2, 2.6.5, 2.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    < 2.5.8>= 2.6.0, < 2.6.5>= 2.7.0, < 2.7.2
    Fixed in
    2.5.8, 2.7.2, 2.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-3617: 1.14% estimated exploitation activity in the next 30 days; percentile 66.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The forumprintlatestdiscussions function in mod/forum/lib.php in Moodle through 2.4.11, 2.5.x before 2.5.8, 2.6.x before 2.6.5, and 2.7.x before 2.7.2 allows remote authenticated users to bypass the individual answer-posting requirement without the mod/forum:viewqandawithoutposting capability, and discover an author's username, by leveraging the student role and visiting a Q&A forum.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p5j7-26wj-423j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-3617

Advisory: Moodle allows discovery of an author's username
IDs: CVE-2014-3617, GHSA-p5j7-26wj-423j
Record: https://patchnext.com/advisories/cve-2014-3617 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.7.2, 2.6.5, 2.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected < 2.5.8; >= 2.6.0, < 2.6.5; >= 2.7.0, < 2.7.2; fixed in 2.5.8, 2.7.2, 2.6.5

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p5j7-26wj-423j (GitHub-reviewed advisory GHSA-p5j7-26wj-423j lists affected ranges: Packagist moodle/moodle >=0 =2.6.0 =2.7.0 <2.7.2)

Commands are suggestions: review each one before running it.

Loading voting…