Skip to content

← Actionable
Unrated

Improper Authentication in Apache WSS4J

CVE-2014-3612GHSA-72m6-23ff-7q26

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-jaas 5.10.1; org.apache.activemq:activemq-broker 5.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-3612: 6.90% estimated exploitation activity in the next 30 days; percentile 94.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind. NOTE: this identifier has been SPLIT per ADT2 due to different vulnerability types. See CVE-2015-6524 for the use of wildcard operators in usernames.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-72m6-23ff-7q26

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-3612

Advisory: Improper Authentication in Apache WSS4J
IDs: CVE-2014-3612, GHSA-72m6-23ff-7q26
Record: https://patchnext.com/advisories/cve-2014-3612 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-jaas 5.10.1; org.apache.activemq:activemq-broker 5.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.activemq:activemq-jaas: affected >= 5.0.0, < 5.10.1; fixed in 5.10.1
- Maven org.apache.activemq:activemq-broker: affected >= 5.0.0, < 5.10.1; fixed in 5.10.1

## Suggested inspection (read-only)
- Maven org.apache.activemq:activemq-jaas: check the installed version with your package manager.
- Maven org.apache.activemq:activemq-broker: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.activemq:activemq-jaas, org.apache.activemq:activemq-broker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-72m6-23ff-7q26 (GitHub-reviewed advisory GHSA-72m6-23ff-7q26 lists affected ranges: Maven org.apache.activemq:activemq-broker >=5.0.0 =5.0.0 <5.10.1)

Commands are suggestions: review each one before running it.

Loading voting…