Loop with Unreachable Exit Condition in Apache CXF
CVE-2014-3584GHSA-gw5j-77f9-v2g2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cxf:cxf-rt-frontend-jaxrs 3.0.1, 2.7.8, 2.6.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.cxf:cxf-rt-frontend-jaxrs
- Affected
- >= 2.7.0, < 2.7.8>= 3.0.0, < 3.0.1>= 2.5.0, < 2.6.11
- Fixed in
- 2.6.11, 3.0.1, 2.7.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gw5j-77f9-v2g2 lists affected ranges: Maven org.apache.cxf:cxf-rt-frontend-jaxrs >=2.7.0 =3.0.0 =2.5.0 <2.6.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-3584: 7.18% estimated exploitation activity in the next 30 days; percentile 94.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The SamlHeaderInHandler in Apache CXF before 2.6.11, 2.7.x before 2.7.8, and 3.0.x before 3.0.1 allows remote attackers to cause a denial of service (infinite loop) via a crafted SAML token in the authorization header of a request to a JAX-RS service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gw5j-77f9-v2g2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3584 Advisory: Loop with Unreachable Exit Condition in Apache CXF IDs: CVE-2014-3584, GHSA-gw5j-77f9-v2g2 Record: https://patchnext.com/advisories/cve-2014-3584 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.cxf:cxf-rt-frontend-jaxrs 3.0.1, 2.7.8, 2.6.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.cxf:cxf-rt-frontend-jaxrs: affected >= 2.7.0, < 2.7.8; >= 3.0.0, < 3.0.1; >= 2.5.0, < 2.6.11; fixed in 2.6.11, 3.0.1, 2.7.8 ## Suggested inspection (read-only) - Maven org.apache.cxf:cxf-rt-frontend-jaxrs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.cxf:cxf-rt-frontend-jaxrs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gw5j-77f9-v2g2 (GitHub-reviewed advisory GHSA-gw5j-77f9-v2g2 lists affected ranges: Maven org.apache.cxf:cxf-rt-frontend-jaxrs >=2.7.0 =3.0.0 =2.5.0 <2.6.11) Commands are suggestions: review each one before running it.
Loading voting…