Skip to content

← Actionable
Unrated

Improper Input Validation in Apache POI

CVE-2014-3574GHSA-5wfp-8643-c58x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.poi:poi 3.11-beta2, 3.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.poi:poi

    Affected
    < 3.10.1>= 3.11-beta1, <= 3.11-beta1
    Fixed in
    3.10.1, 3.11-beta2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-3574: 7.11% estimated exploitation activity in the next 30 days; percentile 94.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5wfp-8643-c58x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-3574

Advisory: Improper Input Validation in Apache POI
IDs: CVE-2014-3574, GHSA-5wfp-8643-c58x
Record: https://patchnext.com/advisories/cve-2014-3574 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.poi:poi 3.11-beta2, 3.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.poi:poi: affected < 3.10.1; >= 3.11-beta1, <= 3.11-beta1; fixed in 3.10.1, 3.11-beta2

## Suggested inspection (read-only)
- Maven org.apache.poi:poi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.poi:poi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5wfp-8643-c58x (GitHub-reviewed advisory GHSA-5wfp-8643-c58x lists affected ranges: Maven org.apache.poi:poi >=0 =3.11-beta1 <=3.11-beta1)

Commands are suggestions: review each one before running it.

Loading voting…