Skip to content

← Actionable
Unrated

Moodle remote code execution via quiz questions

CVE-2014-3545GHSA-3m99-h3hp-w9j7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.7.1, 2.6.4, 2.5.7, 2.4.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 2.7.0, <= 2.7.0>= 2.6.0, <= 2.6.3>= 2.5.0, <= 2.5.6>= 2.4.0, <= 2.4.10
    Fixed in
    2.7.1, 2.4.11, 2.6.4, 2.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-3545: 1.72% estimated exploitation activity in the next 30 days; percentile 77.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote authenticated users to execute arbitrary code via a calculated question in a quiz.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3m99-h3hp-w9j7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-3545

Advisory: Moodle remote code execution via quiz questions
IDs: CVE-2014-3545, GHSA-3m99-h3hp-w9j7
Record: https://patchnext.com/advisories/cve-2014-3545 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.7.1, 2.6.4, 2.5.7, 2.4.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 2.7.0, <= 2.7.0; >= 2.6.0, <= 2.6.3; >= 2.5.0, <= 2.5.6; >= 2.4.0, <= 2.4.10; fixed in 2.7.1, 2.4.11, 2.6.4, 2.5.7

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3m99-h3hp-w9j7 (GitHub-reviewed advisory GHSA-3m99-h3hp-w9j7 lists affected ranges: Packagist moodle/moodle >=2.7.0 =2.6.0 =2.5.0 =2.4.0 <=2.4.10)

Commands are suggestions: review each one before running it.

Loading voting…