Authorization Bypass in Spring Security
CVE-2014-3527GHSA-wmv4-5w76-vp9g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-core 3.2.5, 3.1.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-core
- Affected
- < 3.1.7>= 3.2.0, < 3.2.5
- Fixed in
- 3.2.5, 3.1.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wmv4-5w76-vp9g lists affected ranges: Maven org.springframework.security:spring-security-core >=0 =3.2.0 <3.2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2014-3527: 1.82% estimated exploitation activity in the next 30 days; percentile 78.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using Spring Security's CAS Proxy ticket authentication a malicious CAS Service could trick another CAS Service into authenticating a proxy ticket that was not associated. This is due to the fact that the proxy ticket authentication uses the information from the HttpServletRequest which is populated based upon untrusted information within the HTTP request. This means if there are access control restrictions on which CAS services can authenticate to one another, those restrictions can be bypassed. If users are not using CAS Proxy tickets and not basing access control decisions based upon the CAS Service, then there is no impact to users. Mitigation Users of affected versions should apply the following mitigation: - Users of 3.2x should upgrade to 3.2.5 or later - Users of 3.1.x should upgrade to 3.1.7 or later Credit This issue was identified by David Ohsie and brought to our attention by the CAS Development team.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wmv4-5w76-vp9g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3527 Advisory: Authorization Bypass in Spring Security IDs: CVE-2014-3527, GHSA-wmv4-5w76-vp9g Record: https://patchnext.com/advisories/cve-2014-3527 (revision 1, source checked 26 Oct 2026, 16:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-core 3.2.5, 3.1.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-core: affected < 3.1.7; >= 3.2.0, < 3.2.5; fixed in 3.2.5, 3.1.7 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wmv4-5w76-vp9g (GitHub-reviewed advisory GHSA-wmv4-5w76-vp9g lists affected ranges: Maven org.springframework.security:spring-security-core >=0 =3.2.0 <3.2.5) Commands are suggestions: review each one before running it.
Loading voting…