Apache Wicket Sensitive Data Exposure
CVE-2014-3526GHSA-q7wx-mhx4-jr8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.wicket:wicket-core 7.0.0-M3, 6.17.0, 1.5.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.wicket:wicket-core
- Affected
- < 1.5.12>= 6.0, < 6.17.0>= 7.0.0-M1, < 7.0.0-M3
- Fixed in
- 6.17.0, 1.5.12, 7.0.0-M3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q7wx-mhx4-jr8q lists affected ranges: Maven org.apache.wicket:wicket-core >=0 =6.0 =7.0.0-M1 <7.0.0-M3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2014-3526: 2.30% estimated exploitation activity in the next 30 days; percentile 83.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q7wx-mhx4-jr8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3526 Advisory: Apache Wicket Sensitive Data Exposure IDs: CVE-2014-3526, GHSA-q7wx-mhx4-jr8q Record: https://patchnext.com/advisories/cve-2014-3526 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.wicket:wicket-core 7.0.0-M3, 6.17.0, 1.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.wicket:wicket-core: affected < 1.5.12; >= 6.0, < 6.17.0; >= 7.0.0-M1, < 7.0.0-M3; fixed in 6.17.0, 1.5.12, 7.0.0-M3 ## Suggested inspection (read-only) - Maven org.apache.wicket:wicket-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.wicket:wicket-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q7wx-mhx4-jr8q (GitHub-reviewed advisory GHSA-q7wx-mhx4-jr8q lists affected ranges: Maven org.apache.wicket:wicket-core >=0 =6.0 =7.0.0-M1 <7.0.0-M3) Commands are suggestions: review each one before running it.
Loading voting…