Ansible Arbitrary Code Execution
CVE-2014-3498GHSA-4cvm-5776-jx9f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 1.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ansible
- Affected
- < 1.6.6
- Fixed in
- 1.6.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4cvm-5776-jx9f lists affected ranges: PyPI ansible >=0 <1.6.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4cvm-5776-jx9f lists affected ranges: PyPI ansible >=0 <1.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-3498: 2.52% estimated exploitation activity in the next 30 days; percentile 84.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
User module in ansible before 1.6.6 is vulnerable to command execution. Ansible can get the result of remote command in variable, which may come from untrusted source of input. If the content of variable isn't properly filtered and when attempting to use the variable, it will trigger a function that passes it through jinja 2 template engine that can result into arbitrary command execution. Under certain circumstances, unprivileged user on system that is being managed via ansible can execute code on the managing host under UID of running ansible process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4cvm-5776-jx9f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4cvm-5776-jx9f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3498 Advisory: Ansible Arbitrary Code Execution IDs: CVE-2014-3498, GHSA-4cvm-5776-jx9f Record: https://patchnext.com/advisories/cve-2014-3498 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ansible 1.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ansible: affected < 1.6.6; fixed in 1.6.6 ## Suggested inspection (read-only) - `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ansible. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4cvm-5776-jx9f (OSV record GHSA-4cvm-5776-jx9f lists affected ranges: PyPI ansible >=0 <1.6.6 (fixed)) - Verified: https://github.com/advisories/GHSA-4cvm-5776-jx9f (GitHub-reviewed advisory GHSA-4cvm-5776-jx9f lists affected ranges: PyPI ansible >=0 <1.6.6) Commands are suggestions: review each one before running it.
Loading voting…