Elasticsearch Improper Access Control vulnerability
CVE-2014-3120GHSA-mrfm-jxgf-2h6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.elasticsearch:elasticsearch 1.4.0.Beta1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.elasticsearch:elasticsearch
- Affected
- < 1.4.0.Beta1
- Fixed in
- 1.4.0.Beta1
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2014-3120 to the Known Exploited Vulnerabilities catalog on 2022-03-25.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-03-25).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mrfm-jxgf-2h6v lists affected ranges: Maven org.elasticsearch:elasticsearch >=0 <1.4.0.Beta1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N/E:H
- EPSS
- CVE-2014-3120: 88.56% estimated exploitation activity in the next 30 days; percentile 99.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The default configuration in Elasticsearch before 1.4.0.Beta1 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL expressions and Java code via the source parameter to search. NOTE: this only violates the vendor's intended security policy if the user does not run Elasticsearch in its own independent virtual machine.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mrfm-jxgf-2h6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-3120 Advisory: Elasticsearch Improper Access Control vulnerability IDs: CVE-2014-3120, GHSA-mrfm-jxgf-2h6v Record: https://patchnext.com/advisories/cve-2014-3120 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.elasticsearch:elasticsearch 1.4.0.Beta1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.elasticsearch:elasticsearch: affected < 1.4.0.Beta1; fixed in 1.4.0.Beta1 ## Suggested inspection (read-only) - Maven org.elasticsearch:elasticsearch: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.elasticsearch:elasticsearch. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2014-3120 to the Known Exploited Vulnerabilities catalog on 2022-03-25.) - Verified: https://github.com/advisories/GHSA-mrfm-jxgf-2h6v (GitHub-reviewed advisory GHSA-mrfm-jxgf-2h6v lists affected ranges: Maven org.elasticsearch:elasticsearch >=0 <1.4.0.Beta1) Commands are suggestions: review each one before running it.
Loading voting…