Cross-site scripting vulnerability in includes/actions/InfoAction.php
CVE-2014-2853GHSA-6h86-9r5g-f2h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.22.6, 1.21.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mediawiki/core
- Affected
- < 1.21.9>= 1.22.0, < 1.22.6
- Fixed in
- 1.21.9, 1.22.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6h86-9r5g-f2h5 lists affected ranges: Packagist mediawiki/core >=0 =1.22.0 <1.22.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-2853: 2.39% estimated exploitation activity in the next 30 days; percentile 83.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows remote attackers to inject arbitrary web script or HTML via the sort key in an info action.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6h86-9r5g-f2h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-2853 Advisory: Cross-site scripting vulnerability in includes/actions/InfoAction.php IDs: CVE-2014-2853, GHSA-6h86-9r5g-f2h5 Record: https://patchnext.com/advisories/cve-2014-2853 (revision 1, source checked 26 Oct 2026, 14:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.22.6, 1.21.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mediawiki/core: affected < 1.21.9; >= 1.22.0, < 1.22.6; fixed in 1.21.9, 1.22.6 ## Suggested inspection (read-only) - Packagist mediawiki/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mediawiki/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6h86-9r5g-f2h5 (GitHub-reviewed advisory GHSA-6h86-9r5g-f2h5 lists affected ranges: Packagist mediawiki/core >=0 =1.22.0 <1.22.6) Commands are suggestions: review each one before running it.
Loading voting…