Skip to content

← Actionable
High, CVSS 8.7amended

OpenStack Identity (Keystone) DoS through V3 API authentication chaining

CVE-2014-2828GHSA-6mv3-p2gr-wgqf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 8.0.0a0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI keystone

    Affected
    < 8.0.0a0
    Fixed in
    8.0.0a0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2014-2828: 3.22% estimated exploitation activity in the next 30 days; percentile 88.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The V3 API in OpenStack Identity (Keystone) 2013.1 before 2013.2.4 and icehouse before icehouse-rc2 allows remote attackers to cause a denial of service (CPU consumption) via a large number of the same authentication method in a request, aka "authentication chaining."

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6mv3-p2gr-wgqf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6mv3-p2gr-wgqf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-2828

Advisory: OpenStack Identity (Keystone) DoS through V3 API authentication chaining
IDs: CVE-2014-2828, GHSA-6mv3-p2gr-wgqf
Record: https://patchnext.com/advisories/cve-2014-2828 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: keystone 8.0.0a0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI keystone: affected < 8.0.0a0; fixed in 8.0.0a0

## Suggested inspection (read-only)
- `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keystone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6mv3-p2gr-wgqf (OSV record GHSA-6mv3-p2gr-wgqf lists affected ranges: PyPI keystone >=0 <8.0.0a0 (fixed))
- Verified: https://github.com/advisories/GHSA-6mv3-p2gr-wgqf (GitHub-reviewed advisory GHSA-6mv3-p2gr-wgqf lists affected ranges: PyPI keystone >=0 <8.0.0a0)

Commands are suggestions: review each one before running it.

Loading voting…