Skip to content

← Actionable
Medium, CVSS 5.3

rack-ssl Cross-site Scripting vulnerability

CVE-2014-2538GHSA-v3rr-cph9-2g2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack-ssl 1.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack-ssl

    Affected
    < 1.4.0
    Fixed in
    1.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2014-2538: 2.19% estimated exploitation activity in the next 30 days; percentile 82.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v3rr-cph9-2g2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-2538

Advisory: rack-ssl Cross-site Scripting vulnerability
IDs: CVE-2014-2538, GHSA-v3rr-cph9-2g2q
Record: https://patchnext.com/advisories/cve-2014-2538 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack-ssl 1.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack-ssl: affected < 1.4.0; fixed in 1.4.0

## Suggested inspection (read-only)
- RubyGems rack-ssl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack-ssl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v3rr-cph9-2g2q (GitHub-reviewed advisory GHSA-v3rr-cph9-2g2q lists affected ranges: RubyGems rack-ssl >=0 <1.4.0)

Commands are suggestions: review each one before running it.

Loading voting…