XXE in SabreDAV
CVE-2014-2055GHSA-qm4x-ch5w-gr62
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sabre/dav 1.8.9, 1.7.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sabre/dav
- Affected
- >= 1.6.0, < 1.7.11>= 1.8.0, < 1.8.9
- Fixed in
- 1.7.11, 1.8.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qm4x-ch5w-gr62 lists affected ranges: Packagist sabre/dav >=1.6.0 =1.8.0 <1.8.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-2055: 2.23% estimated exploitation activity in the next 30 days; percentile 82.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qm4x-ch5w-gr62
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-2055 Advisory: XXE in SabreDAV IDs: CVE-2014-2055, GHSA-qm4x-ch5w-gr62 Record: https://patchnext.com/advisories/cve-2014-2055 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sabre/dav 1.8.9, 1.7.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sabre/dav: affected >= 1.6.0, < 1.7.11; >= 1.8.0, < 1.8.9; fixed in 1.7.11, 1.8.9 ## Suggested inspection (read-only) - Packagist sabre/dav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sabre/dav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qm4x-ch5w-gr62 (GitHub-reviewed advisory GHSA-qm4x-ch5w-gr62 lists affected ranges: Packagist sabre/dav >=1.6.0 =1.8.0 <1.8.9) Commands are suggestions: review each one before running it.
Loading voting…