PHPExcel vulnerable to XXE attacks through libxml
CVE-2014-2054GHSA-28rm-rj57-qjpv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpexcel 1.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpoffice/phpexcel
- Affected
- < 1.8.0
- Fixed in
- 1.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-28rm-rj57-qjpv lists affected ranges: Packagist phpoffice/phpexcel >=0 <1.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-2054: 1.54% estimated exploitation activity in the next 30 days; percentile 74.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PHPExcel before 1.8.0, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, does not disable external entity loading in libxml, which allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-28rm-rj57-qjpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-2054 Advisory: PHPExcel vulnerable to XXE attacks through libxml IDs: CVE-2014-2054, GHSA-28rm-rj57-qjpv Record: https://patchnext.com/advisories/cve-2014-2054 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpexcel 1.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpoffice/phpexcel: affected < 1.8.0; fixed in 1.8.0 ## Suggested inspection (read-only) - Packagist phpoffice/phpexcel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpoffice/phpexcel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-28rm-rj57-qjpv (GitHub-reviewed advisory GHSA-28rm-rj57-qjpv lists affected ranges: Packagist phpoffice/phpexcel >=0 <1.8.0) Commands are suggestions: review each one before running it.
Loading voting…