Skip to content

← Actionable
Unrated

Insecure use of temporary files in passenger

CVE-2014-1831GHSA-c7j7-p5jq-26ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (passenger 4.0.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems passenger

    Affected
    < 4.0.38
    Fixed in
    4.0.38

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-1831: 0.37% estimated exploitation activity in the next 30 days; percentile 31.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Phusion Passenger before 4.0.38 allows local users to write to certain files and directories via a symlink attack on 1. controlprocess.pid or 2. a generation- file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c7j7-p5jq-26ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-1831

Advisory: Insecure use of temporary files in passenger
IDs: CVE-2014-1831, GHSA-c7j7-p5jq-26ff
Record: https://patchnext.com/advisories/cve-2014-1831 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: passenger 4.0.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems passenger: affected < 4.0.38; fixed in 4.0.38

## Suggested inspection (read-only)
- RubyGems passenger: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on passenger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c7j7-p5jq-26ff (GitHub-reviewed advisory GHSA-c7j7-p5jq-26ff lists affected ranges: RubyGems passenger >=0 <4.0.38)

Commands are suggestions: review each one before running it.

Loading voting…