Skip to content

← Actionable
Critical, CVSS 9.8

java-xmlbuilder vulnerable to XML External Entity Reference

CVE-2014-125087GHSA-3vrc-rrpw-r5pw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.jamesmurty.utils:java-xmlbuilder 1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2014-125087: 1.24% estimated exploitation activity in the next 30 days; percentile 69.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in java-xmlbuilder up to 1.1. It has been rated as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. Upgrading to version 1.2 is able to address this issue. The name of the patch is e6fddca201790abab4f2c274341c0bb8835c3e73. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-221480.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3vrc-rrpw-r5pw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-125087

Advisory: java-xmlbuilder vulnerable to XML External Entity Reference
IDs: CVE-2014-125087, GHSA-3vrc-rrpw-r5pw
Record: https://patchnext.com/advisories/cve-2014-125087 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.jamesmurty.utils:java-xmlbuilder 1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.jamesmurty.utils:java-xmlbuilder: affected < 1.2; fixed in 1.2

## Suggested inspection (read-only)
- Maven com.jamesmurty.utils:java-xmlbuilder: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.jamesmurty.utils:java-xmlbuilder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3vrc-rrpw-r5pw (GitHub-reviewed advisory GHSA-3vrc-rrpw-r5pw lists affected ranges: Maven com.jamesmurty.utils:java-xmlbuilder >=0 <1.2)

Commands are suggestions: review each one before running it.

Loading voting…