himiklab yii2-jqgrid-widget vulnerable to SQL Injection
CVE-2014-125051GHSA-7mg5-rw39-q67f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (himiklab/yii2-jqgrid-widget 1.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist himiklab/yii2-jqgrid-widget
- Affected
- < 1.0.8
- Fixed in
- 1.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mg5-rw39-q67f lists affected ranges: Packagist himiklab/yii2-jqgrid-widget >=0 <1.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2014-125051: 0.73% estimated exploitation activity in the next 30 days; percentile 54.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 can address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7mg5-rw39-q67f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-125051 Advisory: himiklab yii2-jqgrid-widget vulnerable to SQL Injection IDs: CVE-2014-125051, GHSA-7mg5-rw39-q67f Record: https://patchnext.com/advisories/cve-2014-125051 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: himiklab/yii2-jqgrid-widget 1.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist himiklab/yii2-jqgrid-widget: affected < 1.0.8; fixed in 1.0.8 ## Suggested inspection (read-only) - Packagist himiklab/yii2-jqgrid-widget: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on himiklab/yii2-jqgrid-widget. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7mg5-rw39-q67f (GitHub-reviewed advisory GHSA-7mg5-rw39-q67f lists affected ranges: Packagist himiklab/yii2-jqgrid-widget >=0 <1.0.8) Commands are suggestions: review each one before running it.
Loading voting…