Django data leakage via querystring manipulation in admin
CVE-2014-0483GHSA-rw75-m7gp-92m3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (django 1.6.6, 1.5.9, 1.4.14, 1.7rc3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI django
- Affected
- < 1.4.14>= 1.5, < 1.5.9>= 1.6, < 1.6.6>= 1.7a1, < 1.7rc3
- Fixed in
- 1.5.9, 1.6.6, 1.4.14, 1.7rc3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2014-7 lists affected ranges: PyPI django >=0 =1.5 =1.6 <1.6.6 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rw75-m7gp-92m3 lists affected ranges: PyPI django >=0 =1.5 =1.6 =1.7a1 <1.7rc3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-0483: 1.98% estimated exploitation activity in the next 30 days; percentile 80.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The administrative interface (contrib.admin) in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3 does not check if a field represents a relationship between models, which allows remote authenticated users to obtain sensitive information via a tofield parameter in a popup action to an admin change form page, as demonstrated by a /admin/auth/user/?pop=1&t=password URI.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rw75-m7gp-92m3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record PYSEC-2014-7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0483 Advisory: Django data leakage via querystring manipulation in admin IDs: CVE-2014-0483, GHSA-rw75-m7gp-92m3 Record: https://patchnext.com/advisories/cve-2014-0483 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: django 1.6.6, 1.5.9, 1.4.14, 1.7rc3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI django: affected < 1.4.14; >= 1.5, < 1.5.9; >= 1.6, < 1.6.6; >= 1.7a1, < 1.7rc3; fixed in 1.5.9, 1.6.6, 1.4.14, 1.7rc3 ## Suggested inspection (read-only) - `python -m pip show django`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on django. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2014-7 (OSV record PYSEC-2014-7 lists affected ranges: PyPI django >=0 =1.5 =1.6 <1.6.6 (fixed)) - Verified: https://github.com/advisories/GHSA-rw75-m7gp-92m3 (GitHub-reviewed advisory GHSA-rw75-m7gp-92m3 lists affected ranges: PyPI django >=0 =1.5 =1.6 =1.7a1 <1.7rc3) Commands are suggestions: review each one before running it.
Loading voting…