ovirt-engine-sdk-python improper validation of hostname in x.509 certificate
CVE-2014-0161GHSA-wf9j-m9fv-92gq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ovirt-engine-sdk-python 3.5.0.4, 3.4.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.4.0.7>= 3.5.0.0, < 3.5.0.4
- Fixed in
- 3.5.0.4, 3.4.0.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wf9j-m9fv-92gq lists affected ranges: PyPI ovirt-engine-sdk-python >=0 =3.5.0.0 <3.5.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wf9j-m9fv-92gq lists affected ranges: PyPI ovirt-engine-sdk-python >=0 =3.5.0.0 <3.5.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-0161: 0.42% estimated exploitation activity in the next 30 days; percentile 35.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ovirt-engine-sdk-python before 3.4.0.7 and 3.5.0.4 does not verify that the hostname of the remote endpoint matches the Common Name (CN) or subjectAltName as specified by its x.509 certificate in a TLS/SSL session. This could allow man-in-the-middle attackers to spoof remote endpoints via an arbitrary valid certificate.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wf9j-m9fv-92gq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wf9j-m9fv-92gq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0161 Advisory: ovirt-engine-sdk-python improper validation of hostname in x.509 certificate IDs: CVE-2014-0161, GHSA-wf9j-m9fv-92gq Record: https://patchnext.com/advisories/cve-2014-0161 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ovirt-engine-sdk-python 3.5.0.4, 3.4.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ovirt-engine-sdk-python: affected < 3.4.0.7; >= 3.5.0.0, < 3.5.0.4; fixed in 3.5.0.4, 3.4.0.7 ## Suggested inspection (read-only) - `python -m pip show ovirt-engine-sdk-python`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ovirt-engine-sdk-python. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wf9j-m9fv-92gq (OSV record GHSA-wf9j-m9fv-92gq lists affected ranges: PyPI ovirt-engine-sdk-python >=0 =3.5.0.0 <3.5.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-wf9j-m9fv-92gq (GitHub-reviewed advisory GHSA-wf9j-m9fv-92gq lists affected ranges: PyPI ovirt-engine-sdk-python >=0 =3.5.0.0 <3.5.0.4) Commands are suggestions: review each one before running it.
Loading voting…