actionpack Path Traversal vulnerability
CVE-2014-0130GHSA-6x85-j5j2-27jx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 4.1.1, 4.0.5, 3.2.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionpack
- Affected
- >= 3.0.0, < 3.2.18>= 4.0.0, < 4.0.5>= 4.1.0, < 4.1.1
- Fixed in
- 4.1.1, 3.2.18, 4.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6x85-j5j2-27jx lists affected ranges: RubyGems actionpack >=3.0.0 =4.0.0 =4.1.0 <4.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2014-0130 to the Known Exploited Vulnerabilities catalog on 2022-03-25.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-03-25).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H
- EPSS
- CVE-2014-0130: 53.70% estimated exploitation activity in the next 30 days; percentile 99.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory traversal vulnerability in actionpack/lib/abstractcontroller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6x85-j5j2-27jx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0130 Advisory: actionpack Path Traversal vulnerability IDs: CVE-2014-0130, GHSA-6x85-j5j2-27jx Record: https://patchnext.com/advisories/cve-2014-0130 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: actionpack 4.1.1, 4.0.5, 3.2.18. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionpack: affected >= 3.0.0, < 3.2.18; >= 4.0.0, < 4.0.5; >= 4.1.0, < 4.1.1; fixed in 4.1.1, 3.2.18, 4.0.5 ## Suggested inspection (read-only) - RubyGems actionpack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6x85-j5j2-27jx (GitHub-reviewed advisory GHSA-6x85-j5j2-27jx lists affected ranges: RubyGems actionpack >=3.0.0 =4.0.0 =4.1.0 <4.1.1) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2014-0130 to the Known Exploited Vulnerabilities catalog on 2022-03-25.) Commands are suggestions: review each one before running it.
Loading voting…