Moodle places a session key in a URL
CVE-2014-0125GHSA-j465-7mp6-3xg3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.6.2, 2.5.5, 2.4.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- < 2.4.9>= 2.5.0, < 2.5.5>= 2.6.0, < 2.6.2
- Fixed in
- 2.5.5, 2.4.9, 2.6.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j465-7mp6-3xg3 lists affected ranges: Packagist moodle/moodle >=0 =2.5.0 =2.6.0 <2.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-0125: 1.93% estimated exploitation activity in the next 30 days; percentile 79.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
repository/alfresco/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 places a session key in a URL, which allows remote attackers to bypass intended Alfresco Repository file restrictions by impersonating a file's owner.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j465-7mp6-3xg3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0125 Advisory: Moodle places a session key in a URL IDs: CVE-2014-0125, GHSA-j465-7mp6-3xg3 Record: https://patchnext.com/advisories/cve-2014-0125 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.6.2, 2.5.5, 2.4.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected < 2.4.9; >= 2.5.0, < 2.5.5; >= 2.6.0, < 2.6.2; fixed in 2.5.5, 2.4.9, 2.6.2 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j465-7mp6-3xg3 (GitHub-reviewed advisory GHSA-j465-7mp6-3xg3 lists affected ranges: Packagist moodle/moodle >=0 =2.5.0 =2.6.0 <2.6.2) Commands are suggestions: review each one before running it.
Loading voting…