Arbitrary code execution in Apache Commons BeanUtils
CVE-2014-0114GHSA-p66x-2cv9-qq3v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (commons-beanutils:commons-beanutils 1.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven commons-beanutils:commons-beanutils
- Affected
- >= 1.8.0, < 1.9.4
- Fixed in
- 1.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p66x-2cv9-qq3v lists affected ranges: Maven commons-beanutils:commons-beanutils >=1.8.0 <1.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-0114: 99.03% estimated exploitation activity in the next 30 days; percentile 99.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p66x-2cv9-qq3v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0114 Advisory: Arbitrary code execution in Apache Commons BeanUtils IDs: CVE-2014-0114, GHSA-p66x-2cv9-qq3v Record: https://patchnext.com/advisories/cve-2014-0114 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: commons-beanutils:commons-beanutils 1.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven commons-beanutils:commons-beanutils: affected >= 1.8.0, < 1.9.4; fixed in 1.9.4 ## Suggested inspection (read-only) - Maven commons-beanutils:commons-beanutils: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on commons-beanutils:commons-beanutils. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p66x-2cv9-qq3v (GitHub-reviewed advisory GHSA-p66x-2cv9-qq3v lists affected ranges: Maven commons-beanutils:commons-beanutils >=1.8.0 <1.9.4) Commands are suggestions: review each one before running it.
Loading voting…