Improper Input Validation in Apache Tomcat
CVE-2014-0096GHSA-qprx-q2r7-3rx6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-catalina 8.0.6, 7.0.54, 6.0.40; org.apache.tomcat:tomcat 8.0.6, 7.0.54, 6.0.40), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- < 6.0.40>= 7.0.0, < 7.0.54>= 8.0.0, < 8.0.6
- Fixed in
- 8.0.6, 6.0.40, 7.0.54
Maven org.apache.tomcat:tomcat
- Affected
- < 6.0.40>= 7.0.0, < 7.0.54>= 8.0.0, < 8.0.6
- Fixed in
- 8.0.6, 6.0.40, 7.0.54
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qprx-q2r7-3rx6 lists affected ranges: Maven org.apache.tomcat:tomcat >=0 =7.0.0 =8.0.0 =0 =7.0.0 =8.0.0 <8.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-0096: 6.91% estimated exploitation activity in the next 30 days; percentile 94.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
java/org/apache/catalina/servlets/DefaultServlet.java in the default servlet in Apache Tomcat before 6.0.40, 7.x before 7.0.53, and 8.x before 8.0.4 does not properly restrict XSLT stylesheets, which allows remote attackers to bypass security-manager restrictions and read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qprx-q2r7-3rx6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0096 Advisory: Improper Input Validation in Apache Tomcat IDs: CVE-2014-0096, GHSA-qprx-q2r7-3rx6 Record: https://patchnext.com/advisories/cve-2014-0096 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-catalina 8.0.6, 7.0.54, 6.0.40; org.apache.tomcat:tomcat 8.0.6, 7.0.54, 6.0.40. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected < 6.0.40; >= 7.0.0, < 7.0.54; >= 8.0.0, < 8.0.6; fixed in 8.0.6, 6.0.40, 7.0.54 - Maven org.apache.tomcat:tomcat: affected < 6.0.40; >= 7.0.0, < 7.0.54; >= 8.0.0, < 8.0.6; fixed in 8.0.6, 6.0.40, 7.0.54 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qprx-q2r7-3rx6 (GitHub-reviewed advisory GHSA-qprx-q2r7-3rx6 lists affected ranges: Maven org.apache.tomcat:tomcat >=0 =7.0.0 =8.0.0 =0 =7.0.0 =8.0.0 <8.0.6) Commands are suggestions: review each one before running it.
Loading voting…