net-ldap has weak salt when generating passwords
CVE-2014-0083GHSA-qwgm-mxm4-3q2c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net-ldap 0.16.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems net-ldap
- Affected
- < 0.16.2
- Fixed in
- 0.16.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qwgm-mxm4-3q2c lists affected ranges: RubyGems net-ldap >=0 <0.16.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2014-0083: 0.27% estimated exploitation activity in the next 30 days; percentile 20.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Ruby net-ldap gem before 0.16.2 uses a weak salt when generating SSHA passwords.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qwgm-mxm4-3q2c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0083 Advisory: net-ldap has weak salt when generating passwords IDs: CVE-2014-0083, GHSA-qwgm-mxm4-3q2c Record: https://patchnext.com/advisories/cve-2014-0083 (revision 1, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net-ldap 0.16.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems net-ldap: affected < 0.16.2; fixed in 0.16.2 ## Suggested inspection (read-only) - RubyGems net-ldap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net-ldap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qwgm-mxm4-3q2c (GitHub-reviewed advisory GHSA-qwgm-mxm4-3q2c lists affected ranges: RubyGems net-ldap >=0 <0.16.2) Commands are suggestions: review each one before running it.
Loading voting…