Rails vulnerable to Cross-site Scripting
CVE-2014-0081GHSA-m46p-ggm5-5j83
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 4.0.3, 3.2.17; rails 4.0.3, 3.2.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems actionpack
- Affected
- >= 3.0.0, < 3.2.17>= 4.0.0, < 4.0.3
- Fixed in
- 3.2.17, 4.0.3
RubyGems rails
- Affected
- >= 3.0.0, < 3.2.17>= 4.0.0, < 4.0.3
- Fixed in
- 3.2.17, 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m46p-ggm5-5j83 lists affected ranges: RubyGems rails >=3.0.0 =4.0.0 =3.0.0 =4.0.0 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-0081: 4.03% estimated exploitation activity in the next 30 days; percentile 90.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is an XSS vulnerability in the numbertocurrency, numbertopercentage and numbertohuman helpers in Ruby on Rails. This vulnerability has been assigned the CVE identifier CVE-2014-0081. Versions Affected: All. Fixed Versions: 4.1.0.beta2, 4.0.3, 3.2.17. Impact ------ These helpers allows users to nicely format a numeric value. Some of the parameters to the helper (format, negativeformat and units) are not escaped correctly. Applications which pass user controlled data as one of these parameters are vulnerable to an XSS attack. All users passing user controlled data to these parameters of the number helpers should either upgrade or use one of the workarounds immediately. Releases -------- The 4.1.0.rc1, 4.0.3 and 3.2.17 releases are available at the normal locations. Workarounds ----------- The workaround for this issue is to escape the value passed to the parameter. For example, replace code like this: With code like this Patches ------- To aid users who aren't able to upgrade…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m46p-ggm5-5j83
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0081 Advisory: Rails vulnerable to Cross-site Scripting IDs: CVE-2014-0081, GHSA-m46p-ggm5-5j83 Record: https://patchnext.com/advisories/cve-2014-0081 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: actionpack 4.0.3, 3.2.17; rails 4.0.3, 3.2.17. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems actionpack: affected >= 3.0.0, < 3.2.17; >= 4.0.0, < 4.0.3; fixed in 3.2.17, 4.0.3 - RubyGems rails: affected >= 3.0.0, < 3.2.17; >= 4.0.0, < 4.0.3; fixed in 3.2.17, 4.0.3 ## Suggested inspection (read-only) - RubyGems actionpack: check the installed version with your package manager. - RubyGems rails: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on actionpack, rails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m46p-ggm5-5j83 (GitHub-reviewed advisory GHSA-m46p-ggm5-5j83 lists affected ranges: RubyGems rails >=3.0.0 =4.0.0 =3.0.0 =4.0.0 <4.0.3) Commands are suggestions: review each one before running it.
Loading voting…