Skip to content

← Actionable
Unratedamended

OpenStack Neutron Improper Authentication vulnerability

CVE-2014-0056GHSA-72p9-6gc7-q93r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (neutron 2013.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI neutron

    Affected
    >= 2012.2, < 2013.2.3
    Fixed in
    2013.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2014-0056: 1.44% estimated exploitation activity in the next 30 days; percentile 73.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The l3-agent in OpenStack Neutron 2012.2 before 2013.2.3 does not check the tenant id when creating ports, which allows remote authenticated users to plug ports into the routers of arbitrary tenants via the device id in a port-create command.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-72p9-6gc7-q93r

  2. Revision 1 · created ·

    Published from osv record GHSA-72p9-6gc7-q93r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-0056

Advisory: OpenStack Neutron Improper Authentication vulnerability
IDs: CVE-2014-0056, GHSA-72p9-6gc7-q93r
Record: https://patchnext.com/advisories/cve-2014-0056 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: neutron 2013.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI neutron: affected >= 2012.2, < 2013.2.3; fixed in 2013.2.3

## Suggested inspection (read-only)
- `python -m pip show neutron`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on neutron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-72p9-6gc7-q93r (OSV record GHSA-72p9-6gc7-q93r lists affected ranges: PyPI neutron >=2012.2 <2013.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-72p9-6gc7-q93r (GitHub-reviewed advisory GHSA-72p9-6gc7-q93r lists affected ranges: PyPI neutron >=2012.2 <2013.2.3)

Commands are suggestions: review each one before running it.

Loading voting…