Skip to content

← Actionable
Medium, CVSS 6.1amended

Multiple XSS Filter Bypasses in validator

CVE-2013-7454GHSA-q4qq-fm7q-cwp5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (validator 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2013-7454: 1.85% estimated exploitation activity in the next 30 days; percentile 79.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of validator prior to 1.1.0 are affected by several cross-site scripting vulnerabilities due to bypasses discovered in the blacklist-based filter. Proof of Concept Various inputs that could bypass the filter were discovered: Improper parsing of nested tags: Incomplete filtering of javascript: URIs: UI Redressing: Bypass via Nested Forbidden Strings: Additional bypasses were discovered by Krzysztof Kotowicz in 2012 when auditing CodeIgniter's XSS filtering function, which this code was based off of. Recommendation If you are a developer currently using the xss filter function from the validator package, you should consider replacing it with the escape filter function from the same package. This function replaces all instances of angle brackets (<, ), ampersands, and quotation marks, so no HTML tags will be processed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q4qq-fm7q-cwp5

  2. Revision 1 · created ·

    Published from osv record GHSA-q4qq-fm7q-cwp5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-7454

Advisory: Multiple XSS Filter Bypasses in validator
IDs: CVE-2013-7454, GHSA-q4qq-fm7q-cwp5
Record: https://patchnext.com/advisories/cve-2013-7454 (revision 2, source checked 26 Oct 2026, 12:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: validator 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm validator: affected < 1.1.0; fixed in 1.1.0

## Suggested inspection (read-only)
- `npm ls validator --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on validator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q4qq-fm7q-cwp5 (OSV record GHSA-q4qq-fm7q-cwp5 lists affected ranges: npm validator >=0 <1.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q4qq-fm7q-cwp5 (GitHub-reviewed advisory GHSA-q4qq-fm7q-cwp5 lists affected ranges: npm validator >=0 <1.1.0)

Commands are suggestions: review each one before running it.

Loading voting…