Neo4J vulnerable to Cross-Site Request Forgery
CVE-2013-7259GHSA-x626-q4v7-7xc6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.neo4j:neo4j 2.2.0-M01), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.neo4j:neo4j
- Affected
- < 2.2.0-M01
- Fixed in
- 2.2.0-M01
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x626-q4v7-7xc6 lists affected ranges: Maven org.neo4j:neo4j >=0 <2.2.0-M01
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2013-7259: 1.25% estimated exploitation activity in the next 30 days; percentile 69.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site request forgery (CSRF) vulnerabilities in Neo4J 1.9.2 allow remote attackers to hijack the authentication of administrators for requests that execute arbitrary code, as demonstrated by a request to (1) db/data/ext/GremlinPlugin/graphdb/executescript or (2) db/manage/server/console/.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x626-q4v7-7xc6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-7259 Advisory: Neo4J vulnerable to Cross-Site Request Forgery IDs: CVE-2013-7259, GHSA-x626-q4v7-7xc6 Record: https://patchnext.com/advisories/cve-2013-7259 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.neo4j:neo4j 2.2.0-M01. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.neo4j:neo4j: affected < 2.2.0-M01; fixed in 2.2.0-M01 ## Suggested inspection (read-only) - Maven org.neo4j:neo4j: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.neo4j:neo4j. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x626-q4v7-7xc6 (GitHub-reviewed advisory GHSA-x626-q4v7-7xc6 lists affected ranges: Maven org.neo4j:neo4j >=0 <2.2.0-M01) Commands are suggestions: review each one before running it.
Loading voting…