Exposure of Sensitive Information to an Unauthorized Actor in OpenSAML
CVE-2013-6440GHSA-v723-58jv-2qc4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensaml:opensaml 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opensaml:opensaml
- Affected
- < 2.6.1
- Fixed in
- 2.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v723-58jv-2qc4 lists affected ranges: Maven org.opensaml:opensaml >=0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-6440: 2.75% estimated exploitation activity in the next 30 days; percentile 86.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The (1) BasicParserPool, (2) StaticBasicParserPool, (3) XML Decrypter, and (4) SAML Decrypter in Shibboleth OpenSAML-Java before 2.6.1 set the expandEntityReferences property to true, which allows remote attackers to conduct XML external entity (XXE) attacks via a crafted XML DOCTYPE declaration.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v723-58jv-2qc4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-6440 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in OpenSAML IDs: CVE-2013-6440, GHSA-v723-58jv-2qc4 Record: https://patchnext.com/advisories/cve-2013-6440 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opensaml:opensaml 2.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opensaml:opensaml: affected < 2.6.1; fixed in 2.6.1 ## Suggested inspection (read-only) - Maven org.opensaml:opensaml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opensaml:opensaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v723-58jv-2qc4 (GitHub-reviewed advisory GHSA-v723-58jv-2qc4 lists affected ranges: Maven org.opensaml:opensaml >=0 <2.6.1) Commands are suggestions: review each one before running it.
Loading voting…