Python Swift client is vulnerable to Missing SSL Certificate Check
CVE-2013-6396GHSA-p3xv-97g8-4wmj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-swiftclient 2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-swiftclient
- Affected
- >= 1.0, < 2.0
- Fixed in
- 2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p3xv-97g8-4wmj lists affected ranges: PyPI python-swiftclient >=1.0 <2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p3xv-97g8-4wmj lists affected ranges: PyPI python-swiftclient >=1.0 <2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2013-6396: 0.73% estimated exploitation activity in the next 30 days; percentile 54.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The OpenStack Python client library for Swift (python-swiftclient) from 1.0 before 2.0 does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information via a crafted certificate.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p3xv-97g8-4wmj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p3xv-97g8-4wmj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-6396 Advisory: Python Swift client is vulnerable to Missing SSL Certificate Check IDs: CVE-2013-6396, GHSA-p3xv-97g8-4wmj Record: https://patchnext.com/advisories/cve-2013-6396 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-swiftclient 2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-swiftclient: affected >= 1.0, < 2.0; fixed in 2.0 ## Suggested inspection (read-only) - `python -m pip show python-swiftclient`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-swiftclient. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p3xv-97g8-4wmj (OSV record GHSA-p3xv-97g8-4wmj lists affected ranges: PyPI python-swiftclient >=1.0 <2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-p3xv-97g8-4wmj (GitHub-reviewed advisory GHSA-p3xv-97g8-4wmj lists affected ranges: PyPI python-swiftclient >=1.0 <2.0) Commands are suggestions: review each one before running it.
Loading voting…